手里有一台淘汰下来的笔记本,与其闲置不用,不如用来安装软路由。笔记本一般会有一个有线网卡和一个无线网卡,但我这台笔记本的无线网卡无法使用,只有一个有线的单网口。使用软路由,可以实现更多的网络功能。比如带宽控制、防火墙策略、网络监控、科学上网等等。这里以Openwrt/LEDE(koolshare)为例介绍一下在旧笔记本安装软路由的过程。

拓扑图

物理连接图
物理连接图
等效连接图
等效连接图

安装

下载LEDE镜像

下载地址:http://firmware.koolshare.cn/LEDE_X64_fw867/
有两个版本
openwrt-koolshare-mod-v2.26-r9789-f4b7c27ab5-x86-64-combined-squashfs.img.gz
openwrt-koolshare-mod-v2.26-r9789-f4b7c27ab5-x86-64-uefi-gpt-squashfs.img.gz

制作启动工具

下载的LEDE压缩包(.gz文件)解压后是一个镜像文件(.img文件),这其实是一个已经安装好的系统。类似通过光盘把windows安装到硬盘后,又将Windows系统制作成一个IMG镜像文件一样。所以需要想办法把IMG文件写入笔记本的硬盘。

这里使用的方法是,制作一个U盘PE系统,将LEDE IMG文件复制到U盘。使用PE系统启动笔记本,然后在PE系统里面使用镜像写入工具将LEDE IMG文件写入笔记本的硬盘,这样笔记本就变成一台安装了LEDE系统的路由器了。

当然,也可以将LEDE镜像写入U盘,通过U盘来启动,也就是将LEDE安装到U盘。但我不想浪费一个U盘。

制作PE工具

这里使用U深度PE工具,使用其它PE也一样。

pe工具
pe工具

将PE刻录到U盘后,把LEDE IMG文件复制到U盘。把镜像工具也一起复制到U盘,以防PE没有相关的工具,这里使用WinImage这个软件。

复制Koolshare和WinImage到U盘
复制Koolshare和WinImage到U盘

安装LEDE到笔记本

设置笔记本启动顺序

进入笔记本BIOS,设置启动顺序为U盘

启动PE后,打开U盘中的WinImage,将LEDE/Koolshare镜像刻录到笔记本的硬盘

选择图中所示菜单
选择图中所示菜单
选择笔记本的磁盘
选择笔记本的磁盘
选择Koolshare镜像
选择Koolshare镜像
警告信息,确定后开始复制镜像到磁盘
警告信息,确定后开始复制镜像到磁盘
Koolshare启动完成
Koolshare启动完成
回车后就能看到命令提示符
回车后就能看到命令提示符

配置(使用koolshare的LAN口)

使用LAN口是比较简单的,配置没有使用WAN口那么复杂。以下是使用LAN口的视频。

配置(使用koolshare的WAN口)

这里的例子是使用软路由的WAN口来转发内网的流量,主要作用是能够使用koolshare的防火墙。如果不需要使用防火墙功能,简单地配置LAN口也可以。

修改接口IP

Koolshare的默认配置
LAN口IP:192.168.1.1
LAN口掩码:255.255.255.0

我最终要实现的是将笔记本的网口作为Koolshare的WAN口来做流量转发,而默认情况下,因为Koolshare防火墙的关系,我们并不能从WAN口登录Koolshare,只能通过LAN口登录。

因为Koolshare默认将eth0作为WAN口(笔记本的物理口对应的是Koolshare里的wan口),而IP是配置在LAN口上的,并且LAN口的IP与我光猫的网段不一致,此时并不能ping通笔记本。 即使把IP配置在WAN口上,也因为防火墙的关系而无法登录Web界面。

通过以下步骤实现从WAN口登录Koolshare

  • 将笔记本物理口eth0配置到Koolshare的LAN口
  • 配置LAN口的IP与光猫同一个网段
  • 登录Koolshare后,配置防火墙,使得可以从WAN口登录Web界面
  • 将笔记本物理口eth0配置到Koolshare的WAN口
  • 配置WAN口的IP与光猫同一个网段

将笔记本物理口eth0配置到Koolshare的LAN口,配置LAN口的IP与光猫同一个网段。

[email protected]:~# vim /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdd5:ce4f:a0cd::/48'
config interface 'lan'
option type 'bridge'
option ifname 'eth0 eth1 eth2 eth3'
option proto 'static'
option ipaddr '10.55.55.2' #修改IP
option netmask '255.255.255.224' #修改掩码
option gateway '10.55.55.1' #修改网关
option ip6assign '60'
config interface 'wan'
option ifname 'eth4'
option proto 'dhcp'
option ip6assign '64'
config interface 'wan6'
option ifname 'eth4'
option proto 'dhcpv6'
使用vim打开/etc/config/network 后,按i(英文i)进入编辑模式,修改成上面的值。
修改完成后,按ESC退出vim的编辑模式
然后输入:wq保存并退出

保存后,重启网络让配置生效
[email protected]:~# service network restart
可以ping网关测试一下
[email protected]:~# ping 10.55.55.1

首次登录

在新笔记本浏览器打开10.55.55.2,打开Koolshare登录页面,默认已经有密码(密码为koolshare),直接登录即可。

Koolshare登录界面
Koolshare登录界面

修改防火墙

导航到“网络 – 防火墙 – 基本设置 -区域”,在wan那一行,将入站数据由“拒绝”改为“接受”,这个操作的作用是,允许从wan口登录Koolshare。现在仍然是从LAN口登录的。

WAN-入站数据-接受

配置WAN口

修改wan的接口为eth0
修改wan的接口为eth0
配置wan口的IP、掩码、网关、DNS
配置wan口的IP、掩码、网关、DNS

配置完wan口的物理接口和IP后,保存并应用。 如果不保存就离开“WAN”这个标签,所做的修改就消失了。
不自定义DNS,有可能无法ping外网。

将eth0从lan口删除
将eth0从lan口删除

如果不将eth0从lan口删除,则eth0会同时出现在wan口和lan口,并且IP是相同的,可能会造成不可预测的结果,最好将eth0从lan口删除。

测试公网
测试公网

在LEDE安装Shadowsocks插件

Koolshare可以上网后,进入“酷软 – 未安装”,选择“科学上网插件”安装shadowsocks客户端。

Koolshare酷软
Koolshare酷软
安装好的软件
安装好的软件

如果Shadowsocks连接成功,国外连接是打勾的。

Shadowsocks连接成功
Shadowsocks连接成功

点击“koolss运行状态”可以查看访问外网的IP,“从谷歌测试”显示的是Shadowsocks服务器的IP,如果连接不成功,这里可能是显示500错误。

koolss运行状态
koolss运行状态

测试

在防火墙的“基本设置”里,把“转发”设置为“接受”,这样就允许其它设备从WAN口接收数据,并从WAN口转发到网关。设置后,防火墙“区域 – wan – 区域转发”由REJECT变成ACCEPT。

防火墙“区域 – wan”“入站流量”设置为“接受”,使WAN口可以接收流量
防火墙“区域 – wan”“转发”设置为“接受”

防火墙基本设置,转发设置为“接受”
笔记本网卡设置网关和DNS为Koolshare的IP
笔记本网卡设置网关和DNS为Koolshare的IP
打开Goolge进行连接测试
打开Goolge进行连接测试

其它

恢复出厂设置
[email protected]:~# firstboot
[email protected]:~# reboot

参考资料

6 Responses

  • shangxiao

    你好,想请教一个问题.我这里使用U盘作为启动盘,设置lede系统.
    我这里用两台闲置电脑,一台为台式机,一台为笔记本(联想G480).
    测试台式机作为软路由可以完美运行,
    但是测试笔记本作为软路由却无法运行.
    首先使用笔记本作为软路由的时候,进入到lede系统,ping 外网不通,ping任何网段都不通.
    使用ifconfig命令查看只显示lo信息,不显示eth0和eth6信息.
    使用route命令,什么也不显示.
    我的初步判断是否是笔记本需要设置BIOS,或者是笔记本不支持lede.但是始终无法解决.

    回复
    • arben

      LEDE已经可以启动了,似乎跟BIOS也就没什么关系了。
      不知道是不是lede没有笔记本网卡的驱动?
      可以用ifconfig -a 查看所有网卡,看有没有列出eth0。
      或者dmesg | grep -i eth
      这个命令查看系统的自检,正常情况下会看到网卡的型号和驱动版本,如果没有相关信息,可能是没有驱动。

      回复
  • BEAN

    我旧笔记本成功安装LEDE,但是我的新电脑怎么也进不去koolshare的设置界面?
    我的旧笔记本是THINKPAD SL510,路由器是小米的。
    旧电脑的网口与小米路由器链接,新电脑链接小米路由器。

    回复
    • arben

      检查一下LEDE的IP配置看看,首先LEDE要能ping通小米路由器。

      回复
  • To

    koolshare没有SS插件了 怎么办

    回复
    • T

      google koolss 离线安装包

      回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注